import Foundation
let pattern = #"^(?!.*?(\S).*\1.*\1)(?:\b ?[a-f\d]{2}){16}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Valid matches examples:
33 e0 f1 76 9c 4f a8 6c 01 5d 45 9e 28 db 7b 2a
Invalid matches examples:
c0 b0 f5 60 02 8b 1c a4 41 7c 53 f2 85 20 a0 d1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)