# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*?(\S).*\1.*\1)(?:\b ?[a-f\d]{2}){16}$"
test_str = ("Valid matches examples:\n"
"33 e0 f1 76 9c 4f a8 6c 01 5d 45 9e 28 db 7b 2a\n\n"
"Invalid matches examples:\n"
"c0 b0 f5 60 02 8b 1c a4 41 7c 53 f2 85 20 a0 d1\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.