use strict;
my $str = 'Valid matches examples:
33 e0 f1 76 9c 4f a8 6c 01 5d 45 9e 28 db 7b 2a
Invalid matches examples:
c0 b0 f5 60 02 8b 1c a4 41 7c 53 f2 85 20 a0 d1
';
my $regex = qr/^(?!.*?(\S).*\1.*\1)(?:\b ?[a-f\d]{2}){16}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}