import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "await[\\t\\f\\v ]+((?:[^(),\\n\\]\\[]*(?:\\((?:[^()\\n]|(?:(?:\\([^()\\n]*\\))*|\\((?:[^()\\n]|(?:(?:\\([^()\\n]*\\))*))*\\)))*\\))*)+)";
final String string = "const one = [await 1, await 2]',\n"
+ "const three = await \\'1\\'',\n"
+ "const four = await async function a() { }',\n"
+ "const five = await Promise.resolve(5, 2)',\n"
+ "const six = await Promise.resolve([Promise.resolve(1), Promise.resolve(2)])',\n"
+ "const seven = await requestAsPromise.get(\\'https://jsonplaceholder.typicode.com/test/1\\').body,\n"
+ "const eight = await Promise.all([Promise.resolve(1), Promise.reject(2)]),\n"
+ "const nine = await new Promise((resolve, reject) => { resolve(3) }),\n"
+ "const ten = await new Cache().save(),\n"
+ "const eleven = await Promise.all([co(gen())])";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}