import Foundation
let pattern = #"await[\t\f\v ]+((?:[^(),\n\]\[]*(?:\((?:[^()\n]|(?:(?:\([^()\n]*\))*|\((?:[^()\n]|(?:(?:\([^()\n]*\))*))*\)))*\))*)+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
const one = [await 1, await 2]',
const three = await \'1\'',
const four = await async function a() { }',
const five = await Promise.resolve(5, 2)',
const six = await Promise.resolve([Promise.resolve(1), Promise.resolve(2)])',
const seven = await requestAsPromise.get(\'https://jsonplaceholder.typicode.com/test/1\').body,
const eight = await Promise.all([Promise.resolve(1), Promise.reject(2)]),
const nine = await new Promise((resolve, reject) => { resolve(3) }),
const ten = await new Cache().save(),
const eleven = await Promise.all([co(gen())])
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)