const regex = /await[\t\f\v ]+((?:[^(),\n\]\[]*(?:\((?:[^()\n]|(?:(?:\([^()\n]*\))*|\((?:[^()\n]|(?:(?:\([^()\n]*\))*))*\)))*\))*)+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('await[\\t\\f\\v ]+((?:[^(),\\n\\]\\[]*(?:\\((?:[^()\\n]|(?:(?:\\([^()\\n]*\\))*|\\((?:[^()\\n]|(?:(?:\\([^()\\n]*\\))*))*\\)))*\\))*)+)', 'g')
const str = `const one = [await 1, await 2]',
const three = await \\'1\\'',
const four = await async function a() { }',
const five = await Promise.resolve(5, 2)',
const six = await Promise.resolve([Promise.resolve(1), Promise.resolve(2)])',
const seven = await requestAsPromise.get(\\'https://jsonplaceholder.typicode.com/test/1\\').body,
const eight = await Promise.all([Promise.resolve(1), Promise.reject(2)]),
const nine = await new Promise((resolve, reject) => { resolve(3) }),
const ten = await new Cache().save(),
const eleven = await Promise.all([co(gen())])`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}