import re
regex = re.compile(r"await[\t\f\v ]+((?:[^(),\n\]\[]*(?:\((?:[^()\n]|(?:(?:\([^()\n]*\))*|\((?:[^()\n]|(?:(?:\([^()\n]*\))*))*\)))*\))*)+)")
test_str = ("const one = [await 1, await 2]',\n"
"const three = await \\'1\\'',\n"
"const four = await async function a() { }',\n"
"const five = await Promise.resolve(5, 2)',\n"
"const six = await Promise.resolve([Promise.resolve(1), Promise.resolve(2)])',\n"
"const seven = await requestAsPromise.get(\\'https://jsonplaceholder.typicode.com/test/1\\').body,\n"
"const eight = await Promise.all([Promise.resolve(1), Promise.reject(2)]),\n"
"const nine = await new Promise((resolve, reject) => { resolve(3) }),\n"
"const ten = await new Cache().save(),\n"
"const eleven = await Promise.all([co(gen())])")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")