use strict;
my $str = 'const one = [await 1, await 2]\',
const three = await \\\'1\\\'\',
const four = await async function a() { }\',
const five = await Promise.resolve(5, 2)\',
const six = await Promise.resolve([Promise.resolve(1), Promise.resolve(2)])\',
const seven = await requestAsPromise.get(\\\'https://jsonplaceholder.typicode.com/test/1\\\').body,
const eight = await Promise.all([Promise.resolve(1), Promise.reject(2)]),
const nine = await new Promise((resolve, reject) => { resolve(3) }),
const ten = await new Cache().save(),
const eleven = await Promise.all([co(gen())])';
my $regex = qr/await[\t\f\v ]+((?:[^(),\n\]\[]*(?:\((?:[^()\n]|(?:(?:\([^()\n]*\))*|\((?:[^()\n]|(?:(?:\([^()\n]*\))*))*\)))*\))*)+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}