re = /await[\t\f\v ]+((?:[^(),\n\]\[]*(?:\((?:[^()\n]|(?:(?:\([^()\n]*\))*|\((?:[^()\n]|(?:(?:\([^()\n]*\))*))*\)))*\))*)+)/
str = 'const one = [await 1, await 2]\',
const three = await \\\'1\\\'\',
const four = await async function a() { }\',
const five = await Promise.resolve(5, 2)\',
const six = await Promise.resolve([Promise.resolve(1), Promise.resolve(2)])\',
const seven = await requestAsPromise.get(\\\'https://jsonplaceholder.typicode.com/test/1\\\').body,
const eight = await Promise.all([Promise.resolve(1), Promise.reject(2)]),
const nine = await new Promise((resolve, reject) => { resolve(3) }),
const ten = await new Cache().save(),
const eleven = await Promise.all([co(gen())])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end