# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\b(fees|fee|charge|charges)\b(.+)$/\1\2/gm;t' <<< "fees credit card
fee credit card
charges for interest
charge for interest
charger for device
coffee shop
feeder cattle"