$re = '/^\b(fees|fee|charge|charges)\b(.+)$/m';
$str = 'fees credit card
fee credit card
charges for interest
charge for interest
charger for device
coffee shop
feeder cattle';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;