// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\b(fees|fee|charge|charges)\b(.+)$").unwrap();
let string = "fees credit card
fee credit card
charges for interest
charge for interest
charger for device
coffee shop
feeder cattle";
let substitution = "\\1\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}