const regex = /^\b(fees|fee|charge|charges)\b(.+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\b(fees|fee|charge|charges)\\b(.+)$', 'gm')
const str = `fees credit card
fee credit card
charges for interest
charge for interest
charger for device
coffee shop
feeder cattle`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);