# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(!!|\$\$)([\w-]+)\1/<$2>/gm;t' <<< "My pen cost is !!penCost!! manufactured in $$penYear$$ with colors !!penColor1!! and $$penColor1$$"