$re = '/(!!|\$\$)([\w-]+)\1/m';
$str = 'My pen cost is !!penCost!! manufactured in $$penYear$$ with colors !!penColor1!! and $$penColor1$$';
$subst = "<$2>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;