import Foundation
let pattern = #"(!!|\$\$)([\w-]+)\1"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"My pen cost is !!penCost!! manufactured in $$penYear$$ with colors !!penColor1!! and $$penColor1$$"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$2>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)