# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m-s)^(.+)(\n.+){2}/$1/g;t' <<< "Строка с какими-то буквами,цифрами и символами1
Строка с какими-то буквами,цифрами и символами2
Строка с какими-то буквами,цифрами и символами3
Строка с какими-то буквами,цифрами и символами4
Строка с какими-то буквами,цифрами и символами5
Строка с какими-то буквами,цифрами и символами6
Строка с какими-то буквами,цифрами и символами7"