$re = '/(?m-s)^(.+)(\n.+){2}/';
$str = 'Строка с какими-то буквами,цифрами и символами1
Строка с какими-то буквами,цифрами и символами2
Строка с какими-то буквами,цифрами и символами3
Строка с какими-то буквами,цифрами и символами4
Строка с какими-то буквами,цифрами и символами5
Строка с какими-то буквами,цифрами и символами6
Строка с какими-то буквами,цифрами и символами7';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;