package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m-s)^(.+)(\n.+){2}`)
var str = `Строка с какими-то буквами,цифрами и символами1
Строка с какими-то буквами,цифрами и символами2
Строка с какими-то буквами,цифрами и символами3
Строка с какими-то буквами,цифрами и символами4
Строка с какими-то буквами,цифрами и символами5
Строка с какими-то буквами,цифрами и символами6
Строка с какими-то буквами,цифрами и символами7`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}