#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m-s)^(.+)(\n.+){2}"
Local $sString = "Строка с какими-то буквами,цифрами и символами1" & @CRLF & _
"Строка с какими-то буквами,цифрами и символами2" & @CRLF & _
"Строка с какими-то буквами,цифрами и символами3" & @CRLF & _
"Строка с какими-то буквами,цифрами и символами4" & @CRLF & _
"Строка с какими-то буквами,цифрами и символами5" & @CRLF & _
"Строка с какими-то буквами,цифрами и символами6" & @CRLF & _
"Строка с какими-то буквами,цифрами и символами7"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)