import Foundation
let pattern = #"(?m-s)^(.+)(\n.+){2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Строка с какими-то буквами,цифрами и символами1
Строка с какими-то буквами,цифрами и символами2
Строка с какими-то буквами,цифрами и символами3
Строка с какими-то буквами,цифрами и символами4
Строка с какими-то буквами,цифрами и символами5
Строка с какими-то буквами,цифрами и символами6
Строка с какими-то буквами,цифрами и символами7
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)