const regex = /(?m-s)^(.+)(\n.+){2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m-s)^(.+)(\\n.+){2}', 'g')
const str = `Строка с какими-то буквами,цифрами и символами1
Строка с какими-то буквами,цифрами и символами2
Строка с какими-то буквами,цифрами и символами3
Строка с какими-то буквами,цифрами и символами4
Строка с какими-то буквами,цифрами и символами5
Строка с какими-то буквами,цифрами и символами6
Строка с какими-то буквами,цифрами и символами7`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);