using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(課長(?:補佐(?:代理(?:心得)?)?)?)\b";
string input = @"課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理
課長次第、課長志願
# どれにもマッチしない";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}