re = /\b(課長(?:補佐(?:代理(?:心得)?)?)?)\b/m
str = '課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理
課長次第、課長志願
# どれにもマッチしない'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end