// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(課長(?:補佐(?:代理(?:心得)?)?)?)\b").unwrap();
let string = "課長補佐、課長補佐代理、課長補 佐代理心得
課長心得、課長代理
課長次第、課長志願
# どれにもマッチしない";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}