package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(課長(?:補佐(?:代理(?:心得)?)?)?)\b`)
var str = `課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理
課長次第 、課長志願
# どれにもマッチしない`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}