$re = '/\b(課長(?:補佐(?:代理(?:心得)?)?)?)\b/m';
$str = '課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理
課長次第、課長志願
# どれにもマッチしない';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);