use strict;
my $str = '課長補佐、課長補佐代理、課長補佐代理心得
課長心得、課長代理
課長次第、課長志願
# どれにもマッチしない';
my $regex = qr/\b(課長(?:補佐(?:代理(?:心得)?)?)?)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}