use strict;
my $str = 'df
Ref
0 CU12
1 SE00
2 RLA1234
3 12345
3 RLA456
4 LU00
5 RLA1234MA12
6 RLA1234MA13
7 CU00
8 LU00';
my $regex = qr/(?P<x>\w*?)(?P<y>\d*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}