import re
regex = re.compile(r"(?P<x>\w*?)(?P<y>\d*)$", flags=re.MULTILINE)
test_str = ("df\n"
" Ref\n"
"0 CU12\n"
"1 SE00\n"
"2 RLA1234\n"
"3 12345\n"
"3 RLA456\n"
"4 LU00\n"
"5 RLA1234MA12\n"
"6 RLA1234MA13\n"
"7 CU00\n"
"8 LU00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")