re = /(?P<x>\w*?)(?P<y>\d*)$/m
str = 'df
Ref
0 CU12
1 SE00
2 RLA1234
3 12345
3 RLA456
4 LU00
5 RLA1234MA12
6 RLA1234MA13
7 CU00
8 LU00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end