#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<type>revert)(?:\((?<scope>[a-z-]+)\))?(?<breaking>!)?: (?:|(?:.+\n\n(?:- )?))(?:(?:(?:(?<owner>[\d*a-z~-][\w*.~-]*)\/(?<repository>[\da-z~-][\w.~-]*))|(?<user>[\da-z~-][\w.~-]*))@)?(?<hash>[\da-z]+)"
Local $sString = "revert(release-alpha)!: flex-development/mlly@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d" & @CRLF & _
"revert: flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d" & @CRLF & _
"revert: 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d" & @CRLF & _
"" & @CRLF & _
"revert(release): "release: 1.0.0-alpha.2"" & @CRLF & _
"" & @CRLF & _
"- 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d" & @CRLF & _
"" & @CRLF & _
"revert(release): "release: 1.0.0-alpha.2"" & @CRLF & _
"" & @CRLF & _
"flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")