re = /^(?<type>revert)(?:\((?<scope>[a-z-]+)\))?(?<breaking>!)?: (?:|(?:.+\n\n(?:- )?))(?:(?:(?:(?<owner>[\d*a-z~-][\w*.~-]*)\/(?<repository>[\da-z~-][\w.~-]*))|(?<user>[\da-z~-][\w.~-]*))@)?(?<hash>[\da-z]+)/m
str = 'revert(release-alpha)!: flex-development/mlly@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert: flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert: 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert(release): "release: 1.0.0-alpha.2"
- 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert(release): "release: 1.0.0-alpha.2"
flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end