use strict;
my $str = 'revert(release-alpha)!: flex-development/mlly@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert: flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert: 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert(release): "release: 1.0.0-alpha.2"
- 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert(release): "release: 1.0.0-alpha.2"
flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d';
my $regex = qr/^(?<type>revert)(?:\((?<scope>[a-z-]+)\))?(?<breaking>!)?: (?:|(?:.+\n\n(?:- )?))(?:(?:(?:(?<owner>[\d*a-z~-][\w*.~-]*)\/(?<repository>[\da-z~-][\w.~-]*))|(?<user>[\da-z~-][\w.~-]*))@)?(?<hash>[\da-z]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}