# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<type>revert)(?:\((?<scope>[a-z-]+)\))?(?<breaking>!)?: (?:|(?:.+\n\n(?:- )?))(?:(?:(?:(?<owner>[\d*a-z~-][\w*.~-]*)\/(?<repository>[\da-z~-][\w.~-]*))|(?<user>[\da-z~-][\w.~-]*))@)?(?<hash>[\da-z]+)"
test_str = ("revert(release-alpha)!: flex-development/mlly@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d\n"
"revert: flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d\n"
"revert: 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d\n\n"
"revert(release): \"release: 1.0.0-alpha.2\"\n\n"
"- 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d\n\n"
"revert(release): \"release: 1.0.0-alpha.2\"\n\n"
"flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.