using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<type>revert)(?:\((?<scope>[a-z-]+)\))?(?<breaking>!)?: (?:|(?:.+\n\n(?:- )?))(?:(?:(?:(?<owner>[\d*a-z~-][\w*.~-]*)\/(?<repository>[\da-z~-][\w.~-]*))|(?<user>[\da-z~-][\w.~-]*))@)?(?<hash>[\da-z]+)";
string input = @"revert(release-alpha)!: flex-development/mlly@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert: flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert: 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert(release): ""release: 1.0.0-alpha.2""
- 0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d
revert(release): ""release: 1.0.0-alpha.2""
flexdevelopment@0f2fb6e2a5a11c6558c48bffa02ae881999cfd8d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}