import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE)(?<e>(?:.+\\n\\n|\\Z))(?<i>(?:.+\\n)))(?:(?:^.{4}|\\G.*(?=.{6}$))\\K(?=(?&i){5})|(?:^|\\G.*(?=..$))\\K(?=(?&i){3}(?&e))|(?:^.|\\G.*(?=...$))\\K(?=(?&i){2}(?&e))|(?:^..|\\G.*(?=....$))\\K(?=(?&i)(?&e)))..|...\\K.+(?=(?:...\\n\\n|\\Z))";
final String string = "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n"
+ "aaaaaaaaaaaaaaaaaaaa\n\n"
+ "sdaffdsdfsdsfaadd\n"
+ "afdsafdsfssdsfdfs\n"
+ "afdsfdssdfdssfdsf\n"
+ "asfddsfafsdfdsdsf\n"
+ "asfdsdfafdsafasdf\n\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n"
+ "hellohellohellohellohello\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}