use strict;
my $str = 'aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
';
my $regex = qr/(?(DEFINE)(?<e>(?:.+\n\n|\Z))(?<i>(?:.+\n)))(?:(?:^.{4}|\G.*(?=.{6}$))\K(?=(?&i){5})|(?:^|\G.*(?=..$))\K(?=(?&i){3}(?&e))|(?:^.|\G.*(?=...$))\K(?=(?&i){2}(?&e))|(?:^..|\G.*(?=....$))\K(?=(?&i)(?&e)))..|...\K.+(?=(?:...\n\n|\Z))/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}