re = /(?(DEFINE)(?<e>(?:.+\n\n|\Z))(?<i>(?:.+\n)))(?:(?:^.{4}|\G.*(?=.{6}$))\K(?=(?&i){5})|(?:^|\G.*(?=..$))\K(?=(?&i){3}(?&e))|(?:^.|\G.*(?=...$))\K(?=(?&i){2}(?&e))|(?:^..|\G.*(?=....$))\K(?=(?&i)(?&e)))..|...\K.+(?=(?:...\n\n|\Z))/mx
str = 'aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end