# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE)(?<e>(?:.+\n\n|\Z))(?<i>(?:.+\n)))(?:(?:^.{4}|\G.*(?=.{6}$))\K(?=(?&i){5})|(?:^|\G.*(?=..$))\K(?=(?&i){3}(?&e))|(?:^.|\G.*(?=...$))\K(?=(?&i){2}(?&e))|(?:^..|\G.*(?=....$))\K(?=(?&i)(?&e)))..|...\K.+(?=(?:...\n\n|\Z))
"""
test_str = ("aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n"
"aaaaaaaaaaaaaaaaaaaa\n\n"
"sdaffdsdfsdsfaadd\n"
"afdsafdsfssdsfdfs\n"
"afdsfdssdfdssfdsf\n"
"asfddsfafsdfdsdsf\n"
"asfdsdfafdsafasdf\n\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n"
"hellohellohellohellohello\n\n"
" \n"
" \n"
" \n"
" \n"
" \n"
" \n"
" ")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.