const regex = /(?(DEFINE)(?<e>(?:.+\n\n|\Z))(?<i>(?:.+\n)))(?:(?:^.{4}|\G.*(?=.{6}$))\K(?=(?&i){5})|(?:^|\G.*(?=..$))\K(?=(?&i){3}(?&e))|(?:^.|\G.*(?=...$))\K(?=(?&i){2}(?&e))|(?:^..|\G.*(?=....$))\K(?=(?&i)(?&e)))..|...\K.+(?=(?:...\n\n|\Z))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)(?<e>(?:.+\\n\\n|\\Z))(?<i>(?:.+\\n)))(?:(?:^.{4}|\\G.*(?=.{6}$))\\K(?=(?&i){5})|(?:^|\\G.*(?=..$))\\K(?=(?&i){3}(?&e))|(?:^.|\\G.*(?=...$))\\K(?=(?&i){2}(?&e))|(?:^..|\\G.*(?=....$))\\K(?=(?&i)(?&e)))..|...\\K.+(?=(?:...\\n\\n|\\Z))', 'gm')
const str = `aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
aaaaaaaaaaaaaaaaaaaa
sdaffdsdfsdsfaadd
afdsafdsfssdsfdfs
afdsfdssdfdssfdsf
asfddsfafsdfdsdsf
asfdsdfafdsafasdf
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
hellohellohellohellohello
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}