package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:/[a-z0-9_-]+)+`)
var str = `/news
/news?param1=value1
/news#anchor?param1=value1
/test/news#anchor?param1=value1`
var substitution = "$0/"
fmt.Println(re.ReplaceAllString(str, substitution))
}