$re = '`^(?:/[a-z0-9_-]+)+`m';
$str = '/news
/news?param1=value1
/news#anchor?param1=value1
/test/news#anchor?param1=value1';
$subst = "$0/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;