const regex = new RegExp('^(?:/[a-z0-9_-]+)+', 'gm')
const str = `/news
/news?param1=value1
/news#anchor?param1=value1
/test/news#anchor?param1=value1`;
const subst = `$0/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);