import Foundation
let pattern = #"^(?:/[a-z0-9_-]+)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
/news
/news?param1=value1
/news#anchor?param1=value1
/test/news#anchor?param1=value1
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0/"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)