use strict;
my $str = '/news
/news?param1=value1
/news#anchor?param1=value1
/test/news#anchor?param1=value1';
my $regex = qr`^(?:/[a-z0-9_-]+)+`mp;
my $subst = '$0/';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";