re = /^(?:\/[a-z0-9_-]+)+/m
str = '/news
/news?param1=value1
/news#anchor?param1=value1
/test/news#anchor?param1=value1'
subst = '$0/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result