using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{\{\s*[Gg]tfs feed(?:\s*\|\s*(?:name\s*=\s*(?'name'[^|}]*)(?<!\s)|code\s*=\s*(?'code'[^|}]*)(?<!\s)|url\s*=\s*(?'url'[^|}]*)(?<!\s)|[^|}]*))*\}\}";
string input = @"{{gtfs feed | name = OVapi | code = nl-ovapi | operator = Stichting OpenGeo | url = https://gtfs.ovapi.nl/nl/gtfs-nl.zip}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}