use strict;
my $str = '{{gtfs feed | name = OVapi | code = nl-ovapi | operator = Stichting OpenGeo | url = https://gtfs.ovapi.nl/nl/gtfs-nl.zip}}';
my $regex = qr/\{\{\s*[Gg]tfs feed(?:\s*\|\s*(?:name\s*=\s*(?'name'[^|}]*)(?<!\s)|code\s*=\s*(?'code'[^|}]*)(?<!\s)|url\s*=\s*(?'url'[^|}]*)(?<!\s)|[^|}]*))*\}\}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}