$re = '/\{\{\s*[Gg]tfs feed(?:\s*\|\s*(?:name\s*=\s*(?\'name\'[^|}]*)(?<!\s)|code\s*=\s*(?\'code\'[^|}]*)(?<!\s)|url\s*=\s*(?\'url\'[^|}]*)(?<!\s)|[^|}]*))*\}\}/m';
$str = '{{gtfs feed | name = OVapi | code = nl-ovapi | operator = Stichting OpenGeo | url = https://gtfs.ovapi.nl/nl/gtfs-nl.zip}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);